About This Ticket

Problem in CRUD execution

by 6Lensa / November 5, 2014, 11:03 am

Hi Matt,

I deployed your application in a proper LAMP server, and now it works great. There are some problem with creating table and delete data though:

1. I can't create new table, either with "Build Table" or "Import Data". I have changed all the file permission to 777, but still no luck. When I create a new table using phpmyadmin, the app can read it though. Creating new records also works fine.

2. Actually the delete function works great, but I don't want to delete the record permanently. I just want to hide it or flag it as "deleted", and not showing it. Is it possible to customized your app to do that?

My url: http://e-kut.com/6lensa/ 

Regards,

Sonny

Staff

Hi Sonny, 

1. could you please send the following details to [email protected] (and put the ticket ID in the subject line):

- app user/pass
- cpanel / plesk details
- FTP access

2. to make something like this work, you'd need to modify the script.

Staff

Hi Sonny, 

I just had a look, and tried to create a couple of new tables, some worked and some didn't. When it fails, I receive the following error:

Forbidden

You don't have permission to access /6lensa/index.php/db/newTable on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

This would indicate some sort of server issue. I have seen cases before where, when the POST variable contain certain characters or strings, the server has some security measure kick in and throw an error/404.

I would suggest contacting your hosting provider and explaining the situation to them.

Hi Matt,

Thanks for your help. I now can add table, but still can't import data to create a new table or create new record in a table. Is importing data from csv also affected by server's problem? 

Staff

Nah, I don't think the two issues are related. You are sure the folder permissions to "/tmp" are correct and that the CSV file is properly formatted? Are you getting an error of any kind?

I tried having a look at your application, but it doesn't seem to load for me?

Staff

Closed due to inactivity