About This Ticket

Non-admins cannot see the table

by sparkywoo / October 23, 2014, 10:51 pm

Hello,

I've created new user roles with appropriate permissions.
However, they cannot see data in the table (but they see the table-name tab in the bottom) but it says "No data available in this table." Only the Admin can see tha table.

Any idea why? I'm using a highly-confidential FTP server with confidential data so I cannot share it but can you give any ideas on what I can do to solve this issue?

If there needs to be, I can create a seperate table and give access to that..
 

Staff

Could you share a screenshot of permission checkboxes for this particular table?

Yes. Check it out here: http://puu.sh/coQf7/660c10c0c5.png

I tried all different sorts of permissions to no avail :(

Thanks!

 

 

The permission is set as: {"create":"yes","drop":"yes","Devices":{"select":"yes","delete":"yes","insert":"yes","update":"yes","alter":"yes","private":"yes"}}

(Devices is the table name)

Staff

The last checkbox, labeled "Users can access only their own data" makes sure users can only access data created by them, and since you've turned this option on, they're not seeing any data (I assume they haven't created any records yet). Turning this option off would give them access to all the data in the table.

How do I turn this off as an administrator?

The option to save is off even though I'm logged in as an admin.

Thanks,
Sang Park

Nevermind. It works now. You  can close the ticket!